centos 安装配置git客户端与github连接

参考来源:http://www.cnblogs.com/zhcncn/p/4030078.html
参考来源:https://blog.csdn.net/lp112124/article/details/53924330
在CentOS6以上版本的yum源中有git的版本了,可以直接使用yum源进行安装。
$ sudo yum install git
但是yum源中安装的git版本是1.7.1,太老了,Github等需要的Git版本最低都不能低于1.7.2 。所以我们一般不用上面的方法。而是下载git源码,编译安装。
编译安装的步骤是【3】:

(1)安装依赖的包


yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel gcc perl-ExtUtils-MakeMaker

(2)下载git源码并解压缩


$ wget https://github.com/git/git/archive/v2.3.0.zip
$ unzip v2.3.0.zip
$ cd git-2.3.0

(3)编译安装


将其安装在“/usr/local/git”目录下。

make prefix=/usr/local/git all
sudo make prefix=/usr/local/git install

(4)此时你如果使用git --version 查看git版本

发现git仍然是1.7.1版本。这是因为它默认使用了"/usr/bin"下的git。


你可以用下面的命令查看git所在的路径:

$ whereis git
git: /usr/bin/git /usr/local/git /usr/share/man/man1/git.1.gz

(5)我们要把编译安装的git路径放到环境变量

让它替换"/usr/bin"下的git。为此我们可以修改“/etc/profile”文件(或者/etc/bashrc文件)。


sudo vim /etc/profile

然后在文件的最后一行,添加下面的内容,然后保存退出。

export PATH=/usr/local/git/bin:$PATH

(6)使用source命令应用修改。


source /etc/profile

(7)然后再次使用git --version 查看git版本

发现输出2.3.0,表明安装成功。


git --version

(8)关于与git与github交互

http://blog.csdn.net/lp112124/article/details/53763065


原文:https://blog.csdn.net/lp112124/article/details/53924330

阅读 93

Comments